Qt5Creator toolchain Qt 5.11.3

From ESS-WIKI
Jump to: navigation, search

Prerequisites

Debian10(buster) is highly recommended OS to develop.

All operations in this guide are based on Ubuntu 18.04 LTS 64bit only.
First please install Ubuntu 18.04 LTS 64bit* with minimum 2GB memory.

Installing required packages

Please login and perform the following commands:

$ sudo apt-get install -y build-essential 
$ sudo apt-get install -y qtcreator 
$ sudo apt-get install -y qt5-default 
$ sudo apt-get install -y qt5-doc 
$ sudo apt-get install -y qt5-doc-html qtbase5-doc-html 
$ sudo apt-get install -y qtbase5-examples 
$ sudo apt-get install -y qt5-qmake 
$ sudo apt-get install -y rsync
$ sudo apt-get install -y gcc-8-arm-linux-gnueabihf g++-8-arm-linux-gnueabihf
$ sudo apt-get install -y gcc-8-aarch64-linux-gnu g++-8-aarch64-linux-gnu

Link arm-linux-gnu*-8 to arm-linux-gnu* and aarch64-linux-gnu*-8 to aarch64-linux-gnu*:

$ sudo su
$ cd /usr/bin
$ for f in $(ls arm-linux-gnu*-8);do ln -sf $f $(echo $f|sed "s/-8//");done 
$ for f in $(ls aarch64-linux-gnu*-8);do ln -sf $f $(echo $f|sed "s/-8//");done
$ exit

Installing cross toolchain

Please download RK3288(Password: gm9i) and RK3399(Password: 0kkn) cross compiler toolchain first. Then execute the following command to unzip the cross compiler tool to the /opt directory

For RK3288

$ sudo rm -rf /opt/toolchain_Qt_V5.11.3/rk3288/
$ sudo mkdir -p /opt/toolchain_Qt_V5.11.3/rk3288/
$ sudo tar -zxf rk3288_toolchain_Qt_V5.11.3_*.tar.gz -C /opt/toolchain_Qt_V5.11.3/rk3288/

For RK3399

$ sudo rm -rf /opt/toolchain_Qt_V5.11.3/rk3399/ 
$ sudo mkdir -p /opt/toolchain_Qt_V5.11.3/rk3399/ 
$ sudo tar -zxvf rk3399_toolchain_Qt_V5.11.3_*.tar.gz -C /opt/toolchain_Qt_V5.11.3/rk3399/

Working within QtCreator

The method of using this toolchain with qtcreator is the same as 5.9.4 toolchain. Therefore, you can refer to rk3288_qt5Creator.

However, the following differences need to be noted:

Config QtCreator ---- Qt Versions

  1. Bring up the options dialog using "Tools" -> "Options..."
  2. Select the "Build & Run" page on the left, switch to "Qt Versions" tab, and click "Add..."
  3. Select qmake file
    Select "/opt/toolchain_Qt_V5.11.3/rk3288/sysroot/qmake-debian-buster-armhf".
  4. Input Version name "Qt 5.11.3 (RK3288 )".

RTENOTITLE

Config QtCreator ---- Kits

  1. Bring up the options dialog using "Tools" -> "Options..."
  2. Select the "Build & Run" page on the left, switch to "Kits" tab, and click "Add..."
  3. Click "Add".
    Name
    input "RK3288 toolchain"
    Device Tpye
    Select "Generic Linux Device"
    Device
    Select "RK3288"
    Compiler
    Select "GCC 8(C,arm 32bit in /usr/bin)" and "GCC 8(C++,arm 32bit in /usr/bin)"
    Qt version
    Select "Qt 5.11.3 (RK3288)"

RTENOTITLE